Jump to content

Lenses & Optics

Lens Talk, Filters & Attachments

30 topics in this forum

  1. IRIX 15mm T2.6 PL

    • 0 replies
    • 46 views
    • 0 replies
    • 425 views
    • 5 replies
    • 3470 views
    • 1 reply
    • 3765 views
  2. Mid Range Full Frame Zooms

    • 4 replies
    • 2725 views
    • 4 replies
    • 1643 views
    • 0 replies
    • 1231 views
    • 0 replies
    • 1509 views
    • 3 replies
    • 1955 views
    • 1 reply
    • 1511 views
    • 16 replies
    • 8203 views
    • 27 replies
    • 5986 views
    • 4 replies
    • 2082 views
    • 7 replies
    • 2138 views
  3. RF Mount?

    • 3 replies
    • 2038 views
    • 0 replies
    • 1824 views
    • 10 replies
    • 3557 views
    • 5 replies
    • 2987 views
    • 6 replies
    • 2692 views
    • 1 reply
    • 2604 views
    • 7 replies
    • 2907 views
    • 3 replies
    • 3986 views
    • 4 replies
    • 2434 views
    • 8 replies
    • 2219 views
    • 2 replies
    • 1967 views
  • Popular Topics

  • New Posts

    • Having an issue with this brand new lens. Wont mount on Arri PL mounts due to the locking tabs on the camera hitting the body, prohibiting it from mounting. Mounts ok to Metabones E-PL adapter ok as well as VOCAS adapter,  Pana varicam native and canon c300PL. It seems like the lens doesn't like the chunkier Arri and Sony mounts.  Second issue is flange depth is way off, infinity focuses at between 8' and infinity . Third issue is that when tightened,  the removable light baffle which screws into the back of the lens comes into contact with the rear element housing as it focuses to infinity, making it feel like there is focus resistance when you focus to infinity, when the baffle is loosened significantly , the infinity end  focus comes to a satisfying end stop, as it should.  Looks like ill be sending this back to IRIX USA after reaching out to them. Im wondering if I should just begin return through B&H and have the lens exchanged.  Has anyone dealt with Irix or experienced similar issues? Any advice appreciated.  Thanks
    • Hello, No more issue for me now, but I can't explain how. It seems it's a library related glitch because it was only on a specific library at the time. Sorry, I know how frustrating it can be.
    • Hi Rob, welcome to the forum! 
    • Hello everyone. I'm a video editor & cameraman living in Tokyo. I've been in Japan for over 25 years. Most of my work is corporate video.
×
×
  • Create New...